Difference between revisions of “SwOS/RB250 RB260”

[ad_1]

 
Line 6: Line 6:
  SwOS is configurable from your web browser. It gives you all the basic functionality for a managed switch, plus more: allows to manage port-to-port forwarding, broadcast storm control, apply MAC filter, configure VLANs, mirror traffic, apply bandwidth limitation and even adjust some MAC and IP header fields.  

SwOS is configurable from your web browser. It gives you all the basic functionality for a managed switch, plus more: allows to manage port-to-port forwarding, broadcast storm control, apply MAC filter, configure VLANs, mirror traffic, apply bandwidth limitation and even adjust some MAC and IP header fields.

 

</p>

 

</p>

{{Warning | Each RouterBoard switch series have their own firmware which cannot be installed on other series models! In case wrong installation is accidentally done, correct firmware has to be reinstalled following instructions from “Reinstall SwOS firmware” section below.<br />

+

{{Warning | Each switch series have their own firmware which cannot be installed on other series models! In case wrong installation is accidentally done, correct firmware has to be reinstalled following instructions from “Reinstall SwOS firmware” section below.<br />

 

* RB250GS supports SwOS v1.0 till v1.17.

 

* RB250GS supports SwOS v1.0 till v1.17.

 

* RB260GS supports SwOS v1.7 till v1.17.

 

* RB260GS supports SwOS v1.7 till v1.17.

Line 612: Line 612:
 

<p>It is possible to upload and install SwOS firmware using BOOTP. This example shows how to reinstall SwOS using RouterOS.</p>

 

<p>It is possible to upload and install SwOS firmware using BOOTP. This example shows how to reinstall SwOS using RouterOS.</p>

   

{{Warning | Each RouterBoard switch series have their own firmware which cannot be installed on other series models! In case wrong installation is accidentally done, correct firmware has to be reinstalled following these instructions.<br />

+

{{Warning | Each switch series have their own firmware which cannot be installed on other series models! In case wrong installation is accidentally done, correct firmware has to be reinstalled following these instructions.<br />

 

<br />

 

<br />

 

* RB250GS supports SwOS v1.0 till v1.17.

 

* RB250GS supports SwOS v1.0 till v1.17.


Latest revision as of 16:55, 22 November 2018

Summary

SwOS is an operating system designed specifically for administration of MikroTik switch products.

SwOS is configurable from your web browser. It gives you all the basic functionality for a managed switch, plus more: allows to manage port-to-port forwarding, broadcast storm control, apply MAC filter, configure VLANs, mirror traffic, apply bandwidth limitation and even adjust some MAC and IP header fields.

Icon-warn.png

Warning: Each RouterBOARD switch series have their own firmware which cannot be installed on other series models! In case wrong installation is accidentally done, correct firmware has to be reinstalled following instructions from “Reinstall SwOS firmware” section below.

  • RB250GS supports SwOS v1.0 till v1.17.
  • RB260GS supports SwOS v1.7 till v1.17.
  • RB260GSP supports SwOS v1.11 till v1.17.
  • new RB260GS (CSS106-5G-1S), new RB260GSP (CSS106-1G-4P-1S) supports SwOS v2.0 and newer. See CSS106 series manual.

RB260 series features

Features Description
Forwarding
  • Full non-blocking wirespeed switching
  • Up to 2k MAC entries in Host table
  • Forwarding Database works based on SVL or IVL
  • Port Isolation
  • Port Lock
  • Jumbo frame support – 9198 bytes
Mirroring
VLAN
  • Fully compatible with IEEE802.1Q
  • Port based VLAN
  • VLAN filtering
Quality of Service (QoS)
  • Ingress traffic limiting (by ACL)
  • Egress traffic limiting
Access Control List
  • Ingress ACL tables
  • Up to 32 ACL rules (limited by RouterOS)
  • Classification based on ports, L2, L3, L4 protocol header fields
  • ACL actions include filtering, forwarding and modifying of the protocol header fields

Connecting to the switch

Open your web browser and enter IP address of your switch (192.168.88.1 by default) and login screen will appear.

Alt text SwOS Login

SwOS default IP address: 192.168.88.1, user name: admin and there is no password.

Icon-note.png

Note: MikroTik neighbor discovery protocol tools can be used to discover IP address of Mikrotik switch. Manual:IP/Neighbor_discovery. Currently LLDP is not supported.

Interface Overview

SwOS interface menu consists of several tabs: Link, SFP, Forwarding, Statistics, VLAN, VLANs, Static Hosts, Hosts, SNMP, ACL and System.

Description of buttons in SwOS configuration tool:

  • Append – add new item to the end of the list
  • Apply All – applies current configuration changes
  • Cut – removes item from the list
  • Clear – resets properties of the item
  • Discard Changes – removes unsaved configuration
  • Insert – add new item to the list (places it before current item)
  • Sort – sort VLAN table by VLAN-IDs

  • Change Password – changes password of the switch
  • Logout – logout from current switch
  • Reboot – reboot the switch
  • Reset Configuration – reset configuration back to factory defaults
  • Choose File – browse for upgrade or backup file
  • Upgrade – upgrade firmware of the switch
  • Restore Backup – restore switch configuration using selected backup file
  • Save Backup – generate and download backup file from the switch

System Tab

System Tab performs the following functions:

  • General information about switch
  • Switch management
  • Configuration reset
  • Backup and restore configuration
  • Firmware upgrade

Alt text

General settings

Icon-note.png

Note: SwOS uses a simple algorithm to ensure TCP/IP communication – it just replies to the same IP and MAC address packet came from. This way there is no need for Default Gateway on the device itself.

Property Description
IP Address IP address of the switch
Identity Name of the switch (for Mikrotik neighbor discovery protocol)
Allow From IP address from which the service is accessible. Default value is ‘0.0.0.0/0’ – any address
Allow From Ports List of switch ports from which the service is accessible
Allow From VLAN VLAN ID from which the service is accessible (VLAN Mode on ingress port must be other than disabled in order to connect)
Watchdog Enable or disable system watchdog. It will reset CPU of the switch in case of fault condition
Mikrotik Discovery Protocol Enable or disable Mikrotik neighbor discovery protocol
MAC Address MAC address of the switch (read-only)
Serial Number Serial number of the switch (read-only)
Version Firmware version of the switch (read-only)
Uptime Current switch uptime (read-only)

Password, Backup and Firmware Upgrade

Alt text

System management settings

Firmware can be upgraded/downgraded by selecting firmware file and pressing upgrade button. Switch will reboot automatically after successful upgrade.

PoE and Health (RB260GSP only)

Alt text RB260GSP PoE and Health settings
Property Description
Port1 PoE In Long Cable If enabled, it will turn off short detection on all PoE out ports to allow use of longer ethernet cables. This is potentially dangerous setting and should be used with caution.
Voltage Shows the input voltage measured in volts
Temperature Shows PCB temperature in celsius temperature scale

Link Tab

Link Tab allows you to:

  • Configure Ethernet ports
  • Monitor status of Ethernet ports
Alt text
Property Description
Enabled Enable or disable port
Link Status Current link status (read-only)
Auto Negotiation Enable or disable auto negotiation
Speed Specify speed setting of the port (requires auto negotiation to be disabled)
Full Duplex Specify duplex mode of the port (requires auto negotiation to be disabled)
Flow control Enable or disable 802.3x Flow control

PoE (RB260GSP only)

PoE settings configure Power over Ethernet output on RB260GSP port2-port5 and show PoE status and measurements.

Alt text

RB260GSP PoE Out settings
Property Description
PoE Out Sets PoE out mode of the port:

  • off – All detection and PoE out is turned off
  • auto – Detection is done regarding resistance on the spare pairs to check if port has PoE capability. For port to be turned on measured value should be within range from 3kΩ to 26.5kΩ
  • on – PoE out is enabled regardless of the resistance on the port. Use this with caution as that can damage connected equipment!
  • calibr – Manual port PoE out recalibration. It may be necessary if there are ocasional problems with powering connected devices.
PoE Priority Port priority for PoE out supply. If installation is going over power budged, port with the lowest priority is going to be turned off first. 1 – the highest priority port; 4 – the lowest priority port
PoE Status Current PoE out status of the port (read-only):

  • disabled – PoE out is turned off
  • waiting for load – “auto” mode detects out of range resistance to turn on PoE out
  • powered on – PoE out is turned on
  • short circuit – If it is detected, PoE out is turned off to ensure that there is no additional damage on powered device and no damage on powering device
  • voltage too low – Not enough voltage supplied to turn on device with PoE out
  • current too low – Not enough current supplied to turn on device with PoE out
  • waiting for cable disconnect – Manual recalibration with “calibr” has detected connected device and waits for disconnection to complete the recalibration process
PoE Current Shows current usage on the port measured in miliamperes
PoE Power Shows PoE out power on the port measured in watts

SFP Tab

SFP Tab allows you to:

  • Configure SFP port
  • Monitor status of SFP port
Alt text

Link settings

Property Description
Enabled Enable or disable SFP port
Auto Negotiation Enable or disable auto negotiation of SFP port (some SFP modules may required it disabled in order to work)
Icon-note.png

Note: Using SFP+ 1m/3m DAC cable or S-RJ01 module, the device always shows that link is established even if nothing is connected on other end.

Forwarding Tab

Forwarding Tab provides advanced forwarding options among switch ports, port locking, port mirroring, bandwidth limit and broadcast storm control features.

On RB260 series switches ingress rate per port as well as rate for broadcast traffic can be configured with Access Control List by setting Rate. ACL must have one port per entry to provide bandwidth limiting properly.

Alt text
Property Description
Forwarding Forwarding table – allows or restricts traffic flow between specific ports
Port Lock
  • Port Lock – Enable or disable MAC address learning on this port
  • Lock On First – Enable or disable MAC address learning on this port (MAC address from the first recieved packet will still be learnt)
Port Mirroring
  • Mirror Ingress – Whether traffic entering this port must be copied and forwarded to mirroring target port
  • Mirror Egress – Whether traffic leaving this port must be copied and forwarded to mirroring target port
  • Mirror To – Mirroring target port
Bandwidth Limit
  • Ingress Rate – Limit traffic entering this port (bps) (only supported on RB250GS)
  • Egress Rate – Limit traffic leaving this port (bps)
Broadcast Storm Control
  • Storm Rate – Limit the number of broadcast packets transmitted by an interface (only supported on RB250GS)
  • Include Unicast – Include unicast packets without an entry in host table in Storm Rate limitation (only supported on RB250GS)

Statistics Tab

Provides detailed information about received and transmitted packets.

Alt text

Packet Flow

Packet processing in SwOS is described here: Atheros8316 packet flow diagram

VLAN Tab

VLAN configuration for switch ports.

Alt text
Property Description
VLAN Mode VLAN mode for ingress port:

  • disabled – VLAN table is not used. Switch ignores VLAN tag part of tagged packets
  • optional – Handle packets with VLAN tag ID that is not present in VLAN table just like packets without VLAN tag
  • enabled – Drop packets with VLAN tag ID that is not present in VLAN table. Packets without VLAN tag are treat as tagged packets with Default VLAN ID
  • strict – Same as enable, but also checks VLAN support for inbound interface (drop packets with VLAN tag ID and ingress port that are not present in VLAN table)
VLAN Receive Defines the type of allowed packets on ingress port: any / only tagged / only untagged (only supported on RB260GS)
Default VLAN ID Switch will treat both untagged and “Default VLAN ID” tagged ingress packets as they are tagged with this VLAN ID. It is also used to untag egress traffic if packet’s VLAN ID matches “Default VLAN ID”. The VLAN tag itself will only be added if there is VLAN Header = add if missing specified on egress port
Force VLAN ID Whether to apply Default VLAN ID to incoming packets with VLAN tag
VLAN Header
  • leave as is – if VLAN header is present it remains unchanged
  • always strip – if VLAN header is present it is removed from the packet
  • add if missing – if VLAN header is not present it is added to the packet (VLAN ID will be Default VLAN ID of ingress port)
Icon-note.png

Note: VLAN modes enabled and strict require VLAN ID 1 in VLANs table to allow access of untagged traffic to switch itself.

Example

VLANs Tab

VLAN tables specifies certain forwarding rules for packets that have specific 802.1q tag. Basically the table contains entries that map specific VLAN tag IDs to a group of one or more ports. Packets with VLAN tags leave switch through one or more ports that are set in corresponding table entry. VLAN table works together with destination MAC lookup to determine egress ports. VLAN table supports up to 4096 entries.

RB250GS VLANs tab

Alt text
Property Description
VLAN ID VLAN ID of the packet
Ports Ports the packet should be mapped to

RB260GS VLANs tab

Alt text
Property Description
VLAN ID VLAN ID of the packet
Ports Each port has individual VLAN header options for each VLAN ID. Depending on VLAN mode if lookup is done in this table, egress action of packets is processed by this option. Egress option from VLAN tab is ignored.

Hosts Tab

This table represents dynamically learnt MAC address to port mapping entries. When switch receives a packet from certain port, it adds the packets source MAC address X and port it received the packet from to host table, so when a packet comes in with destination MAC address X it knows to which port it should forward the packet. If the destination MAC address is not present in host table then it forwards the packet to all ports in the group. Dynamic entries take about 5 minutes to time out.

Icon-note.png

Note: RB250G and RB260G series switches support 2048 host table entries.

Alt text
Property Description
Ports Ports the packet should be forwarded to (read-only)
MAC Learned MAC address (read-only)
VLAN ID Learned VLAN ID (read-only) (only supported on RB260GS/RB260GSP)

Static Hosts Tab

Static host table entries. Static entries will take over dynamic if dynamic entry with same mac-address already exists. Also by adding a static entry you get access to some more functionality.

Alt text
Property Description
Ports Ports the packet should be forwarded to
MAC MAC address
VLAN ID VLAN ID (only supported on RB260GS/RB260GSP)
Drop Packet with certain MAC address coming from certain ports can be dropped
Mirror Packet can be cloned and sent to mirror-target port

ACL Tab

An access control list (ACL) rule table is very powerful tool allowing wire speed packet filtering, forwarding and VLAN tagging based on L2,L3 protocol header field conditions. SwOS allow you to implement limited number of access control list rules (32 simple rules (only L2 conditions are used); 16 rules where both L2 and L3 conditions are used; or 8 advanced rules where all L2,L3 and L4 conditions are used). Each rule contains a conditions part and an action part.

Alt text

Access Control List settings

Conditions part parameters

Property Description
From Port that packet came in from
MAC Src Source MAC address and mask
MAC Dst Destination MAC address and mask
Ethertype Protocol encapsulated in the payload of an Ethernet Frame
VLAN VLAN header presence:

VLAN ID VLAN tag ID
Priority Priority in VLAN tag
IP Src (IP/netmask:port) Source IPv4 address, netmask and L4 port number
IP Dst (IP/netmask:port) Destination IPv4 address, netmask and L4 port number
Protocol IP protocol
DSCP IP DSCP field

Action part parameters

Property Description
Redirect To Whether to force new destination ports. If Redirect To is enabled and no ports specified in Redirect To Ports, packet will be dropped
Redirect To Ports Destination ports
Mirror Clones packet and sends it to mirror-target port
Rate Limits bandwidth (bps) (only supported on RB260GS/RB260GSP)
Set VLAN ID Changes the VLAN tag ID, if VLAN tag is present
Priority Changes the VLAN tag priority bits, if VLAN tag is present

SNMP Tab

SNMP Tab consists of settings to monitor the switch remotely.

Available SNMP data:

  • System information
  • System uptime
  • Port status
  • Interface statistics
Alt text SNMP settings
Property Description
Enabled Enable or disable SNMP service
Community SNMP community name
Contact Info Contact information for the NMS
Location Location information for the NMS

Reset

SwOS v1.x – RB260GS and RB260GSP

There are two ways to reset the device to defaults:

Reset button

The only button on the SwOS device. It has two functions:

  • Hold this button during boot time until LED light starts flashing, release the button to reset SwOS configuration (same result as with reset hole)
  • Hold this button during boot time longer, until LED starts to blink twice as fast, and then release it to make the device wait for TFTP firmware upgrade

Jumper reset hole

Located on the bottom of case, behind one of the rubber feet of device – resets SwOS software to defaults. Must short circuit the metallic sides of the hole (with a screwdriver, for example) and boot the device. Hold screwdriver in place until SwOS configuration is cleared.

Reinstall SwOS firmware

It is possible to upload and install SwOS firmware using BOOTP. This example shows how to reinstall SwOS using RouterOS.

Icon-warn.png

Warning: Each RouterBOARD switch series have their own firmware which cannot be installed on other series models! In case wrong installation is accidentally done, correct firmware has to be reinstalled following these instructions.

  • RB250GS supports SwOS v1.0 till v1.17.
  • RB260GS supports SwOS v1.7 till v1.17.
  • RB260GSP supports SwOS v1.11 till v1.17.

  • Configure IP address and DHCP server with BOOTP enabled on the installation router.
/ip address
add address=10.0.0.1/24 interface=ether1
/ip pool
add name=dhcp_pool1 ranges=10.0.0.2-10.0.0.254
/ip dhcp-server
add interface=ether1 address-pool=dhcp_pool1 bootp-support=dynamic disabled=no
/ip dhcp-server network
add address=10.0.0.0/24 gateway=10.0.0.1
  • Upload new SwOS firmware file to the router filesystem.
[admin@MikroTik] /file> print 
 # NAME                     TYPE           SIZE                 CREATION-TIME       
 0 swos-rb260-1.14.lzb     .lzb file        38142              sep/02/2014 08:40:17
/ip tftp
add ip-addresses=10.0.0.0/24 real-filename=swos-rb260-1.14.lzb read-only=yes allow=yes
  • Hold the RESET button of the switch when starting it.
  • After few seconds ACT LED will start blinking. Wait till ACT LED blinks twice as fast and release RESET button.
  • Make ethernet connection between the switch Port1 and ethernet port you configured DHCP server on. After few seconds new firmware should be successfully uploaded and installed.


[ad_2]

Source link

Administrador AcessoWi-Fi.com – Gerente UnicoHost Soluções Web – Engenheiro de Redes

Julio Rossoni

Administrador AcessoWi-Fi.com - Gerente UnicoHost Soluções Web - Engenheiro de Redes

Esse site utiliza o Akismet para reduzir spam. Aprenda como seus dados de comentários são processados.