Como remover o COINHIVE do Mikrotik

Saudações amigos AcessoWi-Fi.com!

Hoje venho trazer uma solução para remoção do vírus que explora vulnerabilidade de seu mikrotik transformando-o em um minerador de crypto-moedas sem sua autorização bem como ocasionando diversas falhas na segurança de sua rede.

Aqueles que tiveram seus Mikrotiks infectados pelo virus CoinHive e precisa remover….
Siga os procedimentos abaixo:

1 – Copie e cole o script abaixo em seu Mikrotik:
Código :

/ip firewall filter remove [find comment=sysadminpxy]
/ip firewall nat remove [find comment=sysadminpxy]
/ip proxy set enabled=no
/ip service disable ftp,www-ssl,api,api-ssl
/user remove ftu
/user group remove ftpgroupe
/system scheduler remove [find where name~"upd"]
/file remove u113.rsc
/system package update set channel=bugfix
:log info "Verificando versao...";
/system package update
check-for-updates once
:delay 1s;
:if ([get installed-version] != [get latest-version]) do={
     :log info "Atualizando versao";
     install;
     } else={
     :log info "Nenhuma atualizacao de versao necessaria"
     }
 
:log info "Verificando firmware...";
/system routerboard
:if ([get current-firmware] != [get upgrade-firmware]) do={
     :log info "Atualizando firmware";
     upgrade;
     :delay 15s;
     /system reboot
     } else={
     :log info "Nenhuma atualizacao de firmware necessaria"
     }

OBS: Repita o passo acima 2x.
Pois na primeira, ele irá remover o vírus e atualizar a RB para a ultima versão Bugfix.
Na segunda, ele irá verificar se precisa atualizar o firmware também.

2 – Altere todas as suas senhas.

3 – Atualize seu Winbox.

Pronto, virus removido.
Agora, não esqueça de manter seus equipamentos atualizados e evitar esse transtorno.

Espero que tenham gostado.

Fonte: UnderLinux

Administrador AcessoWi-Fi.com – Gerente UnicoHost Soluções Web – Engenheiro de Redes

Julio Rossoni

Administrador AcessoWi-Fi.com - Gerente UnicoHost Soluções Web - Engenheiro de Redes